<!DOCTYPE html>
<html lang="en" id="facebook" class="no_js">
<head><meta charset="utf-8" /><meta name="referrer" content="default" id="meta_referrer" /><script nonce="oPMEiBFx">window._cstart=+new Date();</script><script nonce="oPMEiBFx">function envFlush(a){function b(b){for(var c in a)b[c]=a[c]}window.requireLazy?window.requireLazy(["Env"],b):(window.Env=window.Env||{},b(window.Env))}envFlush({"ajaxpipe_token":"AXhmlzxwxVpB8fDEEi8","timeslice_heartbeat_config":{"pollIntervalMs":33,"idleGapThresholdMs":60,"ignoredTimesliceNames":{"requestAnimationFrame":true,"Event listenHandler mousemove":true,"Event listenHandler mouseover":true,"Event listenHandler mouseout":true,"Event listenHandler scroll":true},"isHeartbeatEnabled":true,"isArtilleryOn":false},"shouldLogCounters":true,"timeslice_categories":{"react_render":true,"reflow":true},"sample_continuation_stacktraces":true,"stack_trace_limit":30,"timesliceBufferSize":5000,"show_invariant_decoder":false,"compat_iframe_token":"AQ5eV-wloXpH6aSU_GE","isCQuick":false});</script><style nonce="oPMEiBFx"></style><script nonce="oPMEiBFx">__DEV__=0;CavalryLogger=window.CavalryLogger||function(a){this.lid=a,this.transition=!1,this.metric_collected=!1,this.is_detailed_profiler=!1,this.instrumentation_started=!1,this.pagelet_metrics={},this.events={},this.ongoing_watch={},this.values={t_cstart:window._cstart},this.piggy_values={},this.bootloader_metrics={},this.resource_to_pagelet_mapping={},this.initializeInstrumentation&&this.initializeInstrumentation()},CavalryLogger.prototype.setIsDetailedProfiler=function(a){this.is_detailed_profiler=a;return this},CavalryLogger.prototype.setTTIEvent=function(a){this.tti_event=a;return this},CavalryLogger.prototype.setValue=function(a,b,c,d){d=d?this.piggy_values:this.values;(typeof d[a]==="undefined"||c)&&(d[a]=b);return this},CavalryLogger.prototype.getLastTtiValue=function(){return this.lastTtiValue},CavalryLogger.prototype.setTimeStamp=CavalryLogger.prototype.setTimeStamp||function(a,b,c,d){this.mark(a);var e=this.values.t_cstart||this.values.t_start;e=d?e+d:CavalryLogger.now();this.setValue(a,e,b,c);this.tti_event&&a==this.tti_event&&(this.lastTtiValue=e,this.setTimeStamp("t_tti",b));return this},CavalryLogger.prototype.mark=typeof console==="object"&&console.timeStamp?function(a){console.timeStamp(a)}:function(){},CavalryLogger.prototype.addPiggyback=function(a,b){this.piggy_values[a]=b;return this},CavalryLogger.instances={},CavalryLogger.id=0,CavalryLogger.getInstance=function(a){typeof a==="undefined"&&(a=CavalryLogger.id);CavalryLogger.instances[a]||(CavalryLogger.instances[a]=new CavalryLogger(a));return CavalryLogger.instances[a]},CavalryLogger.setPageID=function(a){if(CavalryLogger.id===0){var b=CavalryLogger.getInstance();CavalryLogger.instances[a]=b;CavalryLogger.instances[a].lid=a;delete CavalryLogger.instances[0]}CavalryLogger.id=a},CavalryLogger.now=function(){return window.performance&&performance.timing&&performance.timing.navigationStart&&performance.now?performance.now()+performance.timing.navigationStart:new Date().getTime()},CavalryLogger.prototype.measureResources=function(){},CavalryLogger.prototype.profileEarlyResources=function(){},CavalryLogger.getBootloaderMetricsFromAllLoggers=function(){},CavalryLogger.start_js=function(){},CavalryLogger.done_js=function(){};CavalryLogger.getInstance().setTTIEvent("t_domcontent");CavalryLogger.prototype.measureResources=function(a,b){if(!this.log_resources)return;var c="bootload/"+a.name;if(this.bootloader_metrics[c]!==void 0||this.ongoing_watch[c]!==void 0)return;var d=CavalryLogger.now();this.ongoing_watch[c]=d;"start_"+c in this.bootloader_metrics||(this.bootloader_metrics["start_"+c]=d);b&&!("tag_"+c in this.bootloader_metrics)&&(this.bootloader_metrics["tag_"+c]=b);if(a.type==="js"){c="js_exec/"+a.name;this.ongoing_watch[c]=d}},CavalryLogger.prototype.stopWatch=function(a){if(this.ongoing_watch[a]){var b=CavalryLogger.now(),c=b-this.ongoing_watch[a];this.bootloader_metrics[a]=c;var d=this.piggy_values;a.indexOf("bootload")===0&&(d.t_resource_download||(d.t_resource_download=0),d.resources_downloaded||(d.resources_downloaded=0),d.t_resource_download+=c,d.resources_downloaded+=1,d["tag_"+a]=="_EF_"&&(d.t_pagelet_cssload_early_resources=b));delete this.ongoing_watch[a]}return this},CavalryLogger.getBootloaderMetricsFromAllLoggers=function(){var a={};Object.values(window.CavalryLogger.instances).forEach(function(b){b.bootloader_metrics&&Object.assign(a,b.bootloader_metrics)});return a},CavalryLogger.start_js=function(a){for(var b=0;b<a.length;++b)CavalryLogger.getInstance().stopWatch("js_exec/"+a[b])},CavalryLogger.done_js=function(a){for(var b=0;b<a.length;++b)CavalryLogger.getInstance().stopWatch("bootload/"+a[b])},CavalryLogger.prototype.profileEarlyResources=function(a){for(var b=0;b<a.length;b++)this.measureResources({name:a[b][0],type:a[b][1]?"js":""},"_EF_")};CavalryLogger.getInstance().log_resources=true;CavalryLogger.getInstance().setIsDetailedProfiler(true);window.CavalryLogger&&CavalryLogger.getInstance().setTimeStamp("t_start");</script><noscript><meta http-equiv="refresh" content="0; URL=/blog/ppl-bench-creating-a-standard-for-benchmarking-probabilistic-programming-languages/?_fb_noscript=1" /></noscript><title id="pageTitle">PPL Bench: Creating a standard for benchmarking probabilistic programming languages</title><meta name="description" content="PPL Bench is an open-source, standardized benchmarking framework for measuring inference performance in probabilistic programming languages." /><link rel="canonical" href="https://ai.facebook.com/blog/ppl-bench-creating-a-standard-for-benchmarking-probabilistic-programming-languages/" /><meta name="viewport" content="width=device-width, initial-scale=1" /><meta name="title" content="PPL Bench: Creating a standard for benchmarking probabilistic programming languages" /><meta name="og:title" content="PPL Bench: Creating a standard for benchmarking probabilistic programming languages" /><meta name="description" content="PPL Bench is an open-source, standardized benchmarking framework for measuring inference performance in probabilistic programming languages." /><meta name="og:description" content="PPL Bench is an open-source, standardized benchmarking framework for measuring inference performance in probabilistic programming languages." /><meta name="og:image" content="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/122174564_823527068401904_6421496198039070291_n.png?_nc_cat=101&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=eqmMANQ8rb4AX_Ssh6V&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=e62979b6859ed76369918b082d116834&amp;oe=5FBA5463" /><meta name="og:url" content="https://ai.facebook.com/blog/ppl-bench-creating-a-standard-for-benchmarking-probabilistic-programming-languages/" /><meta name="url" content="https://ai.facebook.com/blog/ppl-bench-creating-a-standard-for-benchmarking-probabilistic-programming-languages/" /><meta name="twitter:card" content="summary" /><link rel="shortcut icon" href="https://static.xx.fbcdn.net/rsrc.php/v3/yh/r/5ZP3mZo0oAE.png" /><link type="text/css" rel="stylesheet" href="https://static.xx.fbcdn.net/rsrc.php/v3/yI/l/0,cross/q3mHt82SoA9.css?_nc_x=Ij3Wp8lg5Kz" data-bootloader-hash="q0yL9" />
<link type="text/css" rel="stylesheet" href="https://static.xx.fbcdn.net/rsrc.php/v3/yC/l/0,cross/tlx15XEt5Mh.css?_nc_x=Ij3Wp8lg5Kz" data-bootloader-hash="j1sKK" />
<link type="text/css" rel="stylesheet" href="https://static.xx.fbcdn.net/rsrc.php/v3/yQ/l/0,cross/6ObU0DPn-Ad.css?_nc_x=Ij3Wp8lg5Kz" data-bootloader-hash="dow/I" />
<link type="text/css" rel="stylesheet" href="https://static.xx.fbcdn.net/rsrc.php/v3/yF/l/0,cross/pWMr2ApQuqh.css?_nc_x=Ij3Wp8lg5Kz" data-bootloader-hash="/01Fl" />
<link type="text/css" rel="stylesheet" href="https://static.xx.fbcdn.net/rsrc.php/v3/yH/l/0,cross/7K1ZHH8VS5b.css?_nc_x=Ij3Wp8lg5Kz" data-bootloader-hash="+2o4K" />
<link type="text/css" rel="stylesheet" href="https://static.xx.fbcdn.net/rsrc.php/v3/yO/l/0,cross/rNPwv-K48lK.css?_nc_x=Ij3Wp8lg5Kz" data-bootloader-hash="IyDqr" />
<link type="text/css" rel="stylesheet" href="https://static.xx.fbcdn.net/rsrc.php/v3/yU/l/0,cross/2iEZgM2HUCy.css?_nc_x=Ij3Wp8lg5Kz" data-bootloader-hash="1mO9I" />
<link type="text/css" rel="stylesheet" href="https://static.xx.fbcdn.net/rsrc.php/v3/yy/l/0,cross/g1H2niWdvH7.css?_nc_x=Ij3Wp8lg5Kz" data-bootloader-hash="EZUnI" />
<link type="text/css" rel="stylesheet" href="https://static.xx.fbcdn.net/rsrc.php/v3/yO/l/0,cross/pZqFVKEF2tq.css?_nc_x=Ij3Wp8lg5Kz" data-bootloader-hash="C42Om" />
<script src="https://static.xx.fbcdn.net/rsrc.php/v3/yn/r/k4P734hDMmm.js?_nc_x=Ij3Wp8lg5Kz" data-bootloader-hash="ThJUe" nonce="oPMEiBFx"></script>
<script nonce="oPMEiBFx">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</script></head><body class="_605a x1 Locale_en_US" dir="ltr"><script nonce="oPMEiBFx">requireLazy(["bootstrapWebSession"],function(j){j(1603571435)})</script><div class="_li"><div class="_8xs5"><div class="_7gdp"><div class="_7gb8 _8xcd" id="u_0_0"><div class="_7gdj" id="u_0_1"><div class="_7gbc"><a class="_8xc5 _8y8i _8x97 _8w61 _7gbe" href="/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h"><img class="_8zlc _7f2d _7gb9 _8zvb _7gb9 _8zvb img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/105597558_3135808863106723_8338468658194053157_n.svg?_nc_cat=108&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=Hjct4uy19rQAX965NUZ&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=112437cacb465669431734bfc109f2d6&amp;oe=5FBB1717" alt="" /><img class="_8zlc _7f2d _8zvc _8zvc img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/105597558_3135808863106723_8338468658194053157_n.svg?_nc_cat=108&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=Hjct4uy19rQAX965NUZ&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=112437cacb465669431734bfc109f2d6&amp;oe=5FBB1717" alt="" /><img class="_8zlc _7f2d _8zvd _8zvd img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/105597558_3135808863106723_8338468658194053157_n.svg?_nc_cat=108&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=Hjct4uy19rQAX965NUZ&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=112437cacb465669431734bfc109f2d6&amp;oe=5FBB1717" alt="" /></span></a><div class="_8cm8"><div class="_7gbf"><a class="_8xc5 _8y8i _8x97 _8w61 _7gbg _8xc8 _8zvf _8zvg _8xca" href="/research/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_2"><span class="_8x6t _8x94 _8w61 _8w6h">Research<div class="_8-c2"></div></span></a><div class="_8zvj" id="u_0_3"><div class="_8zvk"><a class="_8xc5 _8y8i _8x97 _8w61" href="/research#research-areas" data-id="research-areas" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_4"><span class="_8x6t _8x94 _8w61 _8w6h">Research Areas</span></a><a class="_8xc5 _8y8i _8x97 _8w61" href="/research#notable-papers" data-id="notable-papers" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_5"><span class="_8x6t _8x94 _8w61 _8w6h">Notable Papers</span></a><a class="_8xc5 _8y8i _8x97 _8w61" href="/research#recent-publications" data-id="recent-publications" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_6"><span class="_8x6t _8x94 _8w61 _8w6h">Recent Publications</span></a><a class="_8xc5 _8y8i _8x97 _8w61" href="/research#fundamental-and-applied" data-id="fundamental-and-applied" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_7"><span class="_8x6t _8x94 _8w61 _8w6h">Fundamental &amp; Applied</span></a><a class="_8xc5 _8y8i _8x97 _8w61" href="/research#recent-projects" data-id="recent-projects" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_8"><span class="_8x6t _8x94 _8w61 _8w6h">Recent Projects</span></a></div></div><div class="_8xce"><div class="_8xc5 _8x6t _7g57 _7gbg _8xcb _8xc8" id="u_0_9">Research<div class="_FBAINavMobileDropdown__arrow"><img class="_8zlc _7f2d _FBAINavMobileDropdown__openArrow _FBAINavMobileDropdown__openArrow img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/82984939_485833095455121_15678146753855488_n.svg?_nc_cat=111&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=JzAC0RcCnj8AX_Kjm0A&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=ad367aadc53f576ae3f7b375910dc57f&amp;oe=5FB8AC20" alt="Closed mobile nav bar link dropdown" id="u_0_a" /><img class="_8zlc _7f2d _FBAINavMobileDropdown__closeArrow hidden_elem _FBAINavMobileDropdown__closeArrow hidden_elem img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83118354_799551107205746_2662992071274528768_n.svg?_nc_cat=108&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=r4NTrcPaBsYAX9resqU&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=61f41d234596591fbc21fe45a663dde0&amp;oe=5FB8D855" alt="Open mobile nav bar link dropdown" id="u_0_b" /></div></div><div class="_8xcf" id="u_0_c"><a class="_8xc5 _8y8i _8x97 _8w61 _8xc9 _7gbg _8xc8 _8zvf _8zvg _8xca _7gbg _8xc8 _8zvf _8zvg _8xca" href="/research/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Research<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/research#research-areas" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Research Areas<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/research#notable-papers" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Notable Papers<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/research#recent-publications" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Recent Publications<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/research#fundamental-and-applied" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Fundamental &amp; Applied<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/research#recent-projects" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Recent Projects<div class="_8-c2"></div></span></a></div></div><a class="_8xc5 _8y8i _8x97 _8w61 _7gbg _8xc8 _8zvf" href="/results/?page=1&amp;content_types[0]=publication" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_d"><span class="_8x6t _8x94 _8w61 _8w6h">Publications<div class="_8-c2"></div></span></a><div class="_8zvj" id="u_0_e"><div class="_8zvk"></div></div><a class="_8xc5 _8y8i _8x97 _8w61 _7gbg _8xc8 _8zvf" href="/results/?page=1&amp;sort_by=random&amp;content_types[0]=person" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_f"><span class="_8x6t _8x94 _8w61 _8w6h">People<div class="_8-c2"></div></span></a><div class="_8zvj" id="u_0_g"><div class="_8zvk"></div></div><a class="_8xc5 _8y8i _8x97 _8w61 _7gbg _8xc8 _8zvf _8zvg _8xca" href="/tools/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_h"><span class="_8x6t _8x94 _8w61 _8w6h">Tools<div class="_8-c2"></div></span></a><div class="_8zvj" id="u_0_i"><div class="_8zvk"><a class="_8xc5 _8y8i _8x97 _8w61" href="/tools#frameworks-and-tools" data-id="frameworks-and-tools" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_j"><span class="_8x6t _8x94 _8w61 _8w6h">Frameworks &amp; Tools</span></a><a class="_8xc5 _8y8i _8x97 _8w61" href="/tools#libraries-models-and-datasets" data-id="libraries-models-and-datasets" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_k"><span class="_8x6t _8x94 _8w61 _8w6h">Libraries, Models &amp; Datasets</span></a></div></div><div class="_8xce"><div class="_8xc5 _8x6t _7g57 _7gbg _8xcb _8xc8" id="u_0_l">Tools<div class="_FBAINavMobileDropdown__arrow"><img class="_8zlc _7f2d _FBAINavMobileDropdown__openArrow _FBAINavMobileDropdown__openArrow img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/82984939_485833095455121_15678146753855488_n.svg?_nc_cat=111&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=JzAC0RcCnj8AX_Kjm0A&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=ad367aadc53f576ae3f7b375910dc57f&amp;oe=5FB8AC20" alt="Closed mobile nav bar link dropdown" id="u_0_m" /><img class="_8zlc _7f2d _FBAINavMobileDropdown__closeArrow hidden_elem _FBAINavMobileDropdown__closeArrow hidden_elem img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83118354_799551107205746_2662992071274528768_n.svg?_nc_cat=108&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=r4NTrcPaBsYAX9resqU&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=61f41d234596591fbc21fe45a663dde0&amp;oe=5FB8D855" alt="Open mobile nav bar link dropdown" id="u_0_n" /></div></div><div class="_8xcf" id="u_0_o"><a class="_8xc5 _8y8i _8x97 _8w61 _8xc9 _7gbg _8xc8 _8zvf _8zvg _8xca _7gbg _8xc8 _8zvf _8zvg _8xca" href="/tools/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Tools<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/tools#frameworks-and-tools" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Frameworks &amp; Tools<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/tools#libraries-models-and-datasets" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Libraries, Models &amp; Datasets<div class="_8-c2"></div></span></a></div></div><a class="_8xc5 _8y8i _8x97 _8w61 _7gbg _7gbo _8xc8 _8zvf" href="/blog/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_p"><span class="_8x6t _8x94 _8w61 _8w6h">Blog<div class="_8-c2"></div></span></a><div class="_8zvj" id="u_0_q"><div class="_8zvk"></div></div><a class="_8xc5 _8y8i _8x97 _8w61 _7gbg _8xc8 _8zvf" href="/join-us/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_r"><span class="_8x6t _8x94 _8w61 _8w6h">Join Us<div class="_8-c2"></div></span></a><div class="_8zvj" id="u_0_s"><div class="_8zvk"></div></div></div><div class=""><div><noscript id="u_0_t"></noscript></div></div></div><div class="_7gbs"><img class="_8zlc _7f2d _7gb9 _7gb9 img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83271035_2632912153661839_668787963458486272_n.svg?_nc_cat=107&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=qtD4JgJJlwEAX_sZ9y_&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=3f86451bfec5d33d61b793d0c4a0743a&amp;oe=5FB96906" alt="" id="u_0_u" /><img class="_8zlc _7f2d _7gba _7gba img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83271035_2632912153661839_668787963458486272_n.svg?_nc_cat=107&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=qtD4JgJJlwEAX_sZ9y_&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=3f86451bfec5d33d61b793d0c4a0743a&amp;oe=5FB96906" alt="" id="u_0_v" /><img class="_8zlc _7f2d _7gbp _7gbp img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83062140_636691383771739_7554317247066406912_n.svg?_nc_cat=104&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=K20zqZobgwkAX_90eCX&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=eac9417380dd3def2ac8abff238a7728&amp;oe=5FB9832B" alt="" id="u_0_w" /></div></div><div class="_7hlc"></div><div class="_7gbq" id="u_0_x"><div class="_FBAIV2FooterNavSearchBar__desktop"><div><noscript id="u_0_y"></noscript></div></div><div class="_7gbr"><div><a class="_8xc5 _8y8i _8x97 _8w61 _7gbg _8xc8 _8zvf _8zvg _8xca" href="/research/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_z"><span class="_8x6t _8x94 _8w61 _8w6h">Research<div class="_8-c2"></div></span></a><div class="_8zvj" id="u_0_10"><div class="_8zvk"><a class="_8xc5 _8y8i _8x97 _8w61" href="/research#research-areas" data-id="research-areas" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_11"><span class="_8x6t _8x94 _8w61 _8w6h">Research Areas</span></a><a class="_8xc5 _8y8i _8x97 _8w61" href="/research#notable-papers" data-id="notable-papers" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_12"><span class="_8x6t _8x94 _8w61 _8w6h">Notable Papers</span></a><a class="_8xc5 _8y8i _8x97 _8w61" href="/research#recent-publications" data-id="recent-publications" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_13"><span class="_8x6t _8x94 _8w61 _8w6h">Recent Publications</span></a><a class="_8xc5 _8y8i _8x97 _8w61" href="/research#fundamental-and-applied" data-id="fundamental-and-applied" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_14"><span class="_8x6t _8x94 _8w61 _8w6h">Fundamental &amp; Applied</span></a><a class="_8xc5 _8y8i _8x97 _8w61" href="/research#recent-projects" data-id="recent-projects" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_15"><span class="_8x6t _8x94 _8w61 _8w6h">Recent Projects</span></a></div></div><div class="_8xce"><div class="_8xc5 _8x6t _7g57 _7gbg _8xcb _8xc8" id="u_0_16">Research<div class="_FBAINavMobileDropdown__arrow"><img class="_8zlc _7f2d _FBAINavMobileDropdown__openArrow _FBAINavMobileDropdown__openArrow img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/82984939_485833095455121_15678146753855488_n.svg?_nc_cat=111&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=JzAC0RcCnj8AX_Kjm0A&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=ad367aadc53f576ae3f7b375910dc57f&amp;oe=5FB8AC20" alt="Closed mobile nav bar link dropdown" id="u_0_17" /><img class="_8zlc _7f2d _FBAINavMobileDropdown__closeArrow hidden_elem _FBAINavMobileDropdown__closeArrow hidden_elem img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83118354_799551107205746_2662992071274528768_n.svg?_nc_cat=108&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=r4NTrcPaBsYAX9resqU&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=61f41d234596591fbc21fe45a663dde0&amp;oe=5FB8D855" alt="Open mobile nav bar link dropdown" id="u_0_18" /></div></div><div class="_8xcf" id="u_0_19"><a class="_8xc5 _8y8i _8x97 _8w61 _8xc9 _7gbg _8xc8 _8zvf _8zvg _8xca _7gbg _8xc8 _8zvf _8zvg _8xca" href="/research/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Research<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/research#research-areas" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Research Areas<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/research#notable-papers" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Notable Papers<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/research#recent-publications" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Recent Publications<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/research#fundamental-and-applied" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Fundamental &amp; Applied<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/research#recent-projects" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Recent Projects<div class="_8-c2"></div></span></a></div></div></div><div><a class="_8xc5 _8y8i _8x97 _8w61 _7gbg _8xc8 _8zvf" href="/results/?page=1&amp;content_types[0]=publication" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_1a"><span class="_8x6t _8x94 _8w61 _8w6h">Publications<div class="_8-c2"></div></span></a><div class="_8zvj" id="u_0_1b"><div class="_8zvk"></div></div></div><div><a class="_8xc5 _8y8i _8x97 _8w61 _7gbg _8xc8 _8zvf" href="/results/?page=1&amp;sort_by=random&amp;content_types[0]=person" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_1c"><span class="_8x6t _8x94 _8w61 _8w6h">People<div class="_8-c2"></div></span></a><div class="_8zvj" id="u_0_1d"><div class="_8zvk"></div></div></div><div><a class="_8xc5 _8y8i _8x97 _8w61 _7gbg _8xc8 _8zvf _8zvg _8xca" href="/tools/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_1e"><span class="_8x6t _8x94 _8w61 _8w6h">Tools<div class="_8-c2"></div></span></a><div class="_8zvj" id="u_0_1f"><div class="_8zvk"><a class="_8xc5 _8y8i _8x97 _8w61" href="/tools#frameworks-and-tools" data-id="frameworks-and-tools" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_1g"><span class="_8x6t _8x94 _8w61 _8w6h">Frameworks &amp; Tools</span></a><a class="_8xc5 _8y8i _8x97 _8w61" href="/tools#libraries-models-and-datasets" data-id="libraries-models-and-datasets" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_1h"><span class="_8x6t _8x94 _8w61 _8w6h">Libraries, Models &amp; Datasets</span></a></div></div><div class="_8xce"><div class="_8xc5 _8x6t _7g57 _7gbg _8xcb _8xc8" id="u_0_1i">Tools<div class="_FBAINavMobileDropdown__arrow"><img class="_8zlc _7f2d _FBAINavMobileDropdown__openArrow _FBAINavMobileDropdown__openArrow img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/82984939_485833095455121_15678146753855488_n.svg?_nc_cat=111&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=JzAC0RcCnj8AX_Kjm0A&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=ad367aadc53f576ae3f7b375910dc57f&amp;oe=5FB8AC20" alt="Closed mobile nav bar link dropdown" id="u_0_1j" /><img class="_8zlc _7f2d _FBAINavMobileDropdown__closeArrow hidden_elem _FBAINavMobileDropdown__closeArrow hidden_elem img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83118354_799551107205746_2662992071274528768_n.svg?_nc_cat=108&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=r4NTrcPaBsYAX9resqU&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=61f41d234596591fbc21fe45a663dde0&amp;oe=5FB8D855" alt="Open mobile nav bar link dropdown" id="u_0_1k" /></div></div><div class="_8xcf" id="u_0_1l"><a class="_8xc5 _8y8i _8x97 _8w61 _8xc9 _7gbg _8xc8 _8zvf _8zvg _8xca _7gbg _8xc8 _8zvf _8zvg _8xca" href="/tools/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Tools<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/tools#frameworks-and-tools" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Frameworks &amp; Tools<div class="_8-c2"></div></span></a><a class="_8xc5 _8y8i _8x97 _8w60 _7gbg _7gbo _8xc8 _8xc9" href="/tools#libraries-models-and-datasets" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w60 _8w6h">Libraries, Models &amp; Datasets<div class="_8-c2"></div></span></a></div></div></div><div><a class="_8xc5 _8y8i _8x97 _8w61 _7gbg _7gbo _8xc8 _8zvf" href="/blog/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_1m"><span class="_8x6t _8x94 _8w61 _8w6h">Blog<div class="_8-c2"></div></span></a><div class="_8zvj" id="u_0_1n"><div class="_8zvk"></div></div></div><div><a class="_8xc5 _8y8i _8x97 _8w61 _7gbg _8xc8 _8zvf" href="/join-us/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" id="u_0_1o"><span class="_8x6t _8x94 _8w61 _8w6h">Join Us<div class="_8-c2"></div></span></a><div class="_8zvj" id="u_0_1p"><div class="_8zvk"></div></div></div></div></div></div><div id="u_0_1q"></div></div></div><div><div class="_7h8s"><div></div><div class="_8zlh"></div><div class="_8zlh"></div><div class="_8zli"></div><div class="_8zli"></div><div class="_8zlj"></div><div class="_8za3" data-ms="&#123;&quot;creative&quot;:&quot;section&quot;,&quot;creative_detail&quot;:&quot;section&quot;,&quot;create_type&quot;:&quot;section&quot;,&quot;create_type_detail&quot;:&quot;section&quot;&#125;"><div class="_8zng"><div class="_8znh"><div class="_8zmy"><div class="_8x6u"><h4 class="_8w6a _8w6e _8w60 _8xok _8x78">OPEN SOURCE</h4><h4 class="_8w6a _8w6e _8w60 _8xok _8x78">DEVELOPER TOOLS</h4></div><div class="_8zmz"><h1 class="_8w6a _8w6b _8w61">PPL Bench: Creating a standard for benchmarking probabilistic programming languages</h1></div><p class="_8w6f _8wl0 _8w6h">October 22, 2020</p></div><div class="_8zmv _8zmw"><a role="button" class="_8x6s _8x6w _8x6x _8x76 _8x70 _8w61" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fai.facebook.com%2Fblog%2Fppl-bench-creating-a-standard-for-benchmarking-probabilistic-programming-languages%2F" target="_blank" data-ms="&#123;&quot;creative&quot;:&quot;button&quot;,&quot;creative_detail&quot;:&quot;button&quot;,&quot;create_type&quot;:&quot;button&quot;,&quot;create_type_detail&quot;:&quot;button&quot;&#125;"><div class="_8x6z"><svg fill="none" height="29" width="29" viewBox="0 0 29 29" xmlns="http://www.w3.org/2000/svg"><path class="_8x6_" d="M9 13.75C8.58579 13.75 8.25 14.0858 8.25 14.5C8.25 14.9142 8.58579 15.25 9 15.25V13.75ZM20.5303 15.0303C20.8232 14.7374 20.8232 14.2626 20.5303 13.9697L15.7574 9.1967C15.4645 8.90381 14.9896 8.90381 14.6967 9.1967C14.4038 9.48959 14.4038 9.96447 14.6967 10.2574L18.9393 14.5L14.6967 18.7426C14.4038 19.0355 14.4038 19.5104 14.6967 19.8033C14.9896 20.0962 15.4645 20.0962 15.7574 19.8033L20.5303 15.0303ZM9 15.25H20V13.75H9V15.25Z" fill="#344854"></path><circle cx="14.5" cy="14.5" r="14" stroke="#CCD1D4"></circle></svg></div><div class="_8x6- _8x32">Share on Facebook</div></a><a role="button" class="_8x6s _8x6w _8x6x _8x76 _8x70 _8w61" href="https://l.facebook.com/l.php?u=https%3A%2F%2Ftwitter.com%2Fintent%2Ftweet%3Ftext%3DPPL%2BBench%253A%2BCreating%2Ba%2Bstandard%2Bfor%2Bbenchmarking%2Bprobabilistic%2Bprogramming%2Blanguages%2Bhttps%253A%252F%252Fai.facebook.com%252Fblog%252Fppl-bench-creating-a-standard-for-benchmarking-probabilistic-programming-languages%252F&amp;h=AT0G5CiAQCxgWiscqerPmh7l26H8UaI0p0VdCasC8dBwdEyXyCsL8i2NLU9mQKUhEsE_mK_AC7j-WmSob3VfJZb2XFyrQZWO-gQosC_f7LuZOecqI3C7JLshmc6sZXTOVJUM22JPoZpaSjNA" target="_blank" rel="nofollow" data-ms="&#123;&quot;creative&quot;:&quot;button&quot;,&quot;creative_detail&quot;:&quot;button&quot;,&quot;create_type&quot;:&quot;button&quot;,&quot;create_type_detail&quot;:&quot;button&quot;&#125;" data-lynx-mode="hover"><div class="_8x6z"><svg fill="none" height="29" width="29" viewBox="0 0 29 29" xmlns="http://www.w3.org/2000/svg"><path class="_8x6_" d="M9 13.75C8.58579 13.75 8.25 14.0858 8.25 14.5C8.25 14.9142 8.58579 15.25 9 15.25V13.75ZM20.5303 15.0303C20.8232 14.7374 20.8232 14.2626 20.5303 13.9697L15.7574 9.1967C15.4645 8.90381 14.9896 8.90381 14.6967 9.1967C14.4038 9.48959 14.4038 9.96447 14.6967 10.2574L18.9393 14.5L14.6967 18.7426C14.4038 19.0355 14.4038 19.5104 14.6967 19.8033C14.9896 20.0962 15.4645 20.0962 15.7574 19.8033L20.5303 15.0303ZM9 15.25H20V13.75H9V15.25Z" fill="#344854"></path><circle cx="14.5" cy="14.5" r="14" stroke="#CCD1D4"></circle></svg></div><div class="_8x6- _8x32">Share on Twitter</div></a></div><div class="_8zn9 _99tb"><div class="_8zna"><h2 class="_8w6a _8w6c _8w61">What’s New:</h2><p class="_8w6f _8w61 _8w6h">PPL Bench is an open source benchmark framework for evaluating probabilistic programming languages (PPLs) used for statistical modeling. Researchers can use PPL Bench to build their own reference implementations (a number of PPLs are already included) and to benchmark them all in an apples-to-apples comparison. It’s designed to provide researchers with a standard for evaluating improvements in PPLs and to help researchers and engineers choose the best PPL for their applications. </p><h2 class="_8w6a _8w6c _8w61">What it is:</h2><p class="_8w6f _8w61 _8w6h">PPLs allow statisticians to write probability models in a formal language. In roughly the past two decades, the number of PPLs available to researchers and data scientists has exploded. But each of them comes with its own pros and cons. Some PPLs restrict the range of models they can handle, whereas others are universal languages, meaning they support any computable probability distribution. Depending on performance needs, some PPLs are better suited for different use cases than others, which means the PPL community needs a standard benchmarking process to measure inference performance.</p><p class="_8w6f _8w61 _8w6h">PPL Bench does this by using predictive log likelihood as a standard measurement. We believe it is the most uniform way to measure inference accuracy and convergence rates across all types of PPLs, regardless of engine or model representation. PPL Bench also reports other common metrics used to evaluate statistical models, including effective sample size, R-hat, and inference time. </p><h2 class="_8w6a _8w6c _8w61">Why it matters:</h2><p class="_8w6f _8w61 _8w6h">As part of the PPL research community, we believe that a standardized mechanism for comparing PPLs will accelerate the development of better and faster programming languages for probabilistic modeling. We hope that community contributions will help grow and diversify PPL Bench and encourage wider industrial deployments of PPLs.</p><h2 class="_8w6a _8w6c _8w61">Read the full paper:</h2><p class="_8w6f _8w61 _8w6h"><a class="_8xc5 _8y8i _8x97 _8w61" href="https://l.facebook.com/l.php?u=https%3A%2F%2Farxiv.org%2Fabs%2F2010.08886&amp;h=AT0AM3OM0cXnWJWE5PZFrC2J6wny7hAzdmlwsaCjsmNpOLOYv22QSL9umsblAgVy7rl1zzGFqfgoA5nOHmjOT35ejMMaA2s_LxaTb0GfaaNCIbworYvrNjgjQkJSqSlRiad3kFnS8sFaIDXI" rel="nofollow" target="_blank" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" data-lynx-mode="hover"><span class="_8x6t _8x94 _8w61 _8w6h">PPL Bench: Evaluation framework for probabilistic programming languages </span></a></p><h2 class="_8w6a _8w6c _8w61">Get it on GitHub:</h2><p class="_8w6f _8w61 _8w6h"><a class="_8xc5 _8y8i _8x97 _8w61" href="https://l.facebook.com/l.php?u=https%3A%2F%2Fgithub.com%2Ffacebookresearch%2Fpplbench&amp;h=AT1qiDYRkgg8h1QDtmCFQUOn8b4PETGTobcYYQgxoNcqCxIfG6gejPJA-J4xc0HKF3qQBkomQJ1sX_Eup-nRWmLakX6TSxZrrQymy9l3h5IrOBNfSoUQ8099G0VW5xAaeUxt8XWOulKg3NYi" rel="nofollow" target="_blank" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;" data-lynx-mode="hover"><span class="_8x6t _8x94 _8w61 _8w6h">PPL Bench</span></a></p></div><div class="_8znc"><div class="_8zne"><h2 class="_8w6a _8w6c _8w61">Written By</h2></div><div class="_8znd"><div class="_8znf" id="u_0_1r"><div class="_8xm7" data-ms="&#123;&quot;creative&quot;:&quot;card&quot;,&quot;creative_detail&quot;:&quot;card&quot;,&quot;create_type&quot;:&quot;card&quot;,&quot;create_type_detail&quot;:&quot;card&quot;&#125;"><div class="_8wpt"><div class="_8y3f"><div class="_8zmo"><div class="_8y3g"><div class=""><h4 class="_8w6a _8w6e _8w61">Bradford Cottel</h4></div></div><p class="_8w6f _8xm4 _8w61 _8w6g">Technical Program Manager</p></div></div></div></div></div><div class="_8znf" id="u_0_1s"><div class="_8xm7" data-ms="&#123;&quot;creative&quot;:&quot;card&quot;,&quot;creative_detail&quot;:&quot;card&quot;,&quot;create_type&quot;:&quot;card&quot;,&quot;create_type_detail&quot;:&quot;card&quot;&#125;"><div class="_8wpt"><div class="_8y3f"><div class="_8zmo"><div class="_8y3g"><div class=""><h4 class="_8w6a _8w6e _8w61">Kinjal Shah</h4></div></div><p class="_8w6f _8xm4 _8w61 _8w6g">Software Engineer</p></div></div></div></div></div><div class="_8znf" id="u_0_1t"><div class="_8xm7" data-ms="&#123;&quot;creative&quot;:&quot;card&quot;,&quot;creative_detail&quot;:&quot;card&quot;,&quot;create_type&quot;:&quot;card&quot;,&quot;create_type_detail&quot;:&quot;card&quot;&#125;"><div class="_8wpt"><div class="_8y3f"><div class="_8zmo"><div class="_8y3g"><div class=""><h4 class="_8w6a _8w6e _8w61">Nimar Arora</h4></div></div><p class="_8w6f _8xm4 _8w61 _8w6g">Research Scientist</p></div></div></div></div></div></div></div></div></div><div class="_8zni"><div class="_8zmv _8zmr"><a role="button" class="_8x6s _8x6w _8x6x _8x76 _8x70 _8w61" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fai.facebook.com%2Fblog%2Fppl-bench-creating-a-standard-for-benchmarking-probabilistic-programming-languages%2F" target="_blank" data-ms="&#123;&quot;creative&quot;:&quot;button&quot;,&quot;creative_detail&quot;:&quot;button&quot;,&quot;create_type&quot;:&quot;button&quot;,&quot;create_type_detail&quot;:&quot;button&quot;&#125;"><div class="_8x6z"><svg fill="none" height="29" width="29" viewBox="0 0 29 29" xmlns="http://www.w3.org/2000/svg"><path class="_8x6_" d="M9 13.75C8.58579 13.75 8.25 14.0858 8.25 14.5C8.25 14.9142 8.58579 15.25 9 15.25V13.75ZM20.5303 15.0303C20.8232 14.7374 20.8232 14.2626 20.5303 13.9697L15.7574 9.1967C15.4645 8.90381 14.9896 8.90381 14.6967 9.1967C14.4038 9.48959 14.4038 9.96447 14.6967 10.2574L18.9393 14.5L14.6967 18.7426C14.4038 19.0355 14.4038 19.5104 14.6967 19.8033C14.9896 20.0962 15.4645 20.0962 15.7574 19.8033L20.5303 15.0303ZM9 15.25H20V13.75H9V15.25Z" fill="#344854"></path><circle cx="14.5" cy="14.5" r="14" stroke="#CCD1D4"></circle></svg></div><div class="_8x6- _8x32">Share on Facebook</div></a><a role="button" class="_8x6s _8x6w _8x6x _8x76 _8x70 _8w61" href="https://l.facebook.com/l.php?u=https%3A%2F%2Ftwitter.com%2Fintent%2Ftweet%3Ftext%3DPPL%2BBench%253A%2BCreating%2Ba%2Bstandard%2Bfor%2Bbenchmarking%2Bprobabilistic%2Bprogramming%2Blanguages%2Bhttps%253A%252F%252Fai.facebook.com%252Fblog%252Fppl-bench-creating-a-standard-for-benchmarking-probabilistic-programming-languages%252F&amp;h=AT03y2dOS7VUM6lD9EMnIG_KyP0LHEqYqd5v3IJA5Y_B0KtddxwR7vHMY48__YYqCPNCPzNpP9vppP52KyZXIsBjA7ggQuTKcfhhu0aV3MK3TPze5SK7c6BsWga2myiHcLTGQMsrxtCeSXhX" target="_blank" rel="nofollow" data-ms="&#123;&quot;creative&quot;:&quot;button&quot;,&quot;creative_detail&quot;:&quot;button&quot;,&quot;create_type&quot;:&quot;button&quot;,&quot;create_type_detail&quot;:&quot;button&quot;&#125;" data-lynx-mode="hover"><div class="_8x6z"><svg fill="none" height="29" width="29" viewBox="0 0 29 29" xmlns="http://www.w3.org/2000/svg"><path class="_8x6_" d="M9 13.75C8.58579 13.75 8.25 14.0858 8.25 14.5C8.25 14.9142 8.58579 15.25 9 15.25V13.75ZM20.5303 15.0303C20.8232 14.7374 20.8232 14.2626 20.5303 13.9697L15.7574 9.1967C15.4645 8.90381 14.9896 8.90381 14.6967 9.1967C14.4038 9.48959 14.4038 9.96447 14.6967 10.2574L18.9393 14.5L14.6967 18.7426C14.4038 19.0355 14.4038 19.5104 14.6967 19.8033C14.9896 20.0962 15.4645 20.0962 15.7574 19.8033L20.5303 15.0303ZM9 15.25H20V13.75H9V15.25Z" fill="#344854"></path><circle cx="14.5" cy="14.5" r="14" stroke="#CCD1D4"></circle></svg></div><div class="_8x6- _8x32">Share on Twitter</div></a></div><div class="_8zn3"><div class="_8zn4"><div class="_8xiq"><div class="_8xmc"><h3 class="_8w6a _8w6d _8w60">Our Work</h3></div><div class="_8xmd _8xmh"><div class="_8x7m _8x8q _8x92 _8xme _8xmf"><div class="_8xm7" data-ms="&#123;&quot;creative&quot;:&quot;card&quot;,&quot;creative_detail&quot;:&quot;card&quot;,&quot;create_type&quot;:&quot;card&quot;,&quot;create_type_detail&quot;:&quot;card&quot;&#125;"><div class="_8wpt"><a href="https://ai.facebook.com/blog/open-sourcing-pytext-for-faster-nlp-development/" class="_8wrb"><div class="_8wpu"><div class="_8-qn _8xhs"><div class="_8wpv"><img class="_8zlc _7f2d _8zjt _8zjw img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/51650984_640310823072514_5320189784990154752_n.jpg?_nc_cat=104&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=Zd-b7pbeKx4AX9TXkia&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=078824e5ae6fd3d54da04365b1c66f91&amp;oe=5FBB52B8" alt="" /></div></div><div class="_8xhs"><div class="_8wpx"><div class="_8wpy"><div class="_8x6u"><h4 class="_8w6a _8w6e _8w60 _8xok _8x78">NLP</h4><h4 class="_8w6a _8w6e _8w60 _8xok _8x78">OPEN SOURCE</h4></div></div><div class="_8wpz"><h4 class="_8w6a _8w6e _8w61">Open-sourcing PyText for faster NLP development</h4></div><div class="_8wp-"><div id="u_0_1u"></div></div><div class="_8wp_"><p class="_8w6f _8xm4 _8w60 _8w6h">December 14, 2018</p></div></div></div></div></a></div></div></div><div class="_8x7m _8x8q _8x92 _8xme _8xmf"><div class="_8xm7" data-ms="&#123;&quot;creative&quot;:&quot;card&quot;,&quot;creative_detail&quot;:&quot;card&quot;,&quot;create_type&quot;:&quot;card&quot;,&quot;create_type_detail&quot;:&quot;card&quot;&#125;"><div class="_8wpt"><a href="https://ai.facebook.com/blog/expanding-automatic-machine-translation-to-more-languages/" class="_8wrb"><div class="_8wpu"><div class="_8-qn _8xhs"><div class="_8wpv"><img class="_8zlc _7f2d _8zjt _8zjw img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/50919198_1068412246695014_8700438194946048000_n.png?_nc_cat=103&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=6HAQUE_gYNcAX9rUcYJ&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=f76288eafabf156a90f62bfd2313c1cc&amp;oe=5FBAD08F" alt="" /></div></div><div class="_8xhs"><div class="_8wpx"><div class="_8wpy"><div class="_8x6u"><h4 class="_8w6a _8w6e _8w60 _8xok _8x78">ML APPLICATIONS</h4></div></div><div class="_8wpz"><h4 class="_8w6a _8w6e _8w61">Expanding automatic machine translation to more languages</h4></div><div class="_8wp-"><div id="u_0_1v"></div></div><div class="_8wp_"><p class="_8w6f _8xm4 _8w60 _8w6h">September 11, 2018</p></div></div></div></div></a></div></div></div></div></div></div><div class="_8zn5"><div class="_8zn8"></div><div class="_8zn6 _8zm-"></div></div></div></div></div></div></div><div></div></div><div class="_7f9y _8xdf"><div class="_7f9z"><div class="_7f9x _8xdd"><div class="_8za3" data-ms="&#123;&quot;creative&quot;:&quot;section&quot;,&quot;creative_detail&quot;:&quot;section&quot;,&quot;create_type&quot;:&quot;section&quot;,&quot;create_type_detail&quot;:&quot;section&quot;&#125;"><div class="_7f90"><div class="_7ot8"><div class="_8-bz"><div class="_7f91"><div class="_8xe1"><a class="_8xc5 _8x97 _8w61 _7ot6 _8-c1" href="/tools" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Tools</span></a><div class="_7fa4"><div class="_7fa5"><a class="_8xc5 _8y8i _8x97 _8w61 _7f94" href="/tools#frameworks-and-tools" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Frameworks &amp; Tools
            </span></a></div></div></div><div class="_8xe1"><a class="_8xc5 _8x97 _8w61 _7ot6 _8-c1" href="/research" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Research</span></a><div class="_7fa4"><div class="_7fa5"><a class="_8xc5 _8y8i _8x97 _8w61 _7f94" href="/research#research-areas" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Research Areas
            </span></a></div><div class="_7fa5"><a class="_8xc5 _8y8i _8x97 _8w61 _7f94" href="/research#notable-papers" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Notable Papers
            </span></a></div><div class="_7fa5"><a class="_8xc5 _8y8i _8x97 _8w61 _7f94" href="/research#recent-publications" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Recent Publications
            </span></a></div><div class="_7fa5"><a class="_8xc5 _8y8i _8x97 _8w61 _7f94" href="/research#fundamental-and-applied" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Fundamental &amp; Applied
            </span></a></div><div class="_7fa5"><a class="_8xc5 _8y8i _8x97 _8w61 _7f94" href="/research#recent-projects" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Recent Projects
            </span></a></div></div></div><div class="_8xe1"><a class="_8xc5 _8x97 _8w61 _7ot6 _8-c1" href="/blog" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Blog</span></a><div class="_7fa4"><div class="_7fa5"><a class="_8xc5 _8y8i _8x97 _8w61 _7f94" href="/blog" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Read Blog
            </span></a></div></div></div><div class="_8xe1"><a class="_8xc5 _8x97 _8w61 _7ot6 _8-c1" href="/results/?page=1&amp;sort_by=random&amp;content_types[0]=person" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">People</span></a><div class="_7fa4"><div class="_7fa5"><a class="_8xc5 _8y8i _8x97 _8w61 _7f94" href="/results/?page=1&amp;sort_by=random&amp;content_types[0]=person" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              People Profiles
            </span></a></div></div></div><div class="_8xe1"><a class="_8xc5 _8x97 _8w61 _7ot6 _8-c1" href="https://www.facebook.com/careers/jobs?sub_teams[0]=Artificial%20Intelligence" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Join Us</span></a><div class="_7fa4"><div class="_7fa5"><a class="_8xc5 _8y8i _8x97 _8w61 _7f94" href="https://www.facebook.com/careers/jobs?sub_teams[0]=Artificial%20Intelligence" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Jobs
            </span></a></div></div></div></div><img class="_8zlc _7f2d _8-b- _8-b- img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/87524316_2677189655726266_6338721200264445952_n.svg?_nc_cat=103&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=4-zQVEnAOWMAX93T5F9&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=e559929721848208079fb1fa07c1c577&amp;oe=5FBAC938" alt="" id="u_0_1w" /></div><div class="_7ot7"><div class="_8z0n _FBAIV2FooterNavSearchBar__desktop"><div><noscript id="u_0_1x"></noscript></div></div><div class="_7spo"><div class="_7sp9"><a href="https://www.facebook.com/facebookai" target="_blank"><div class="_7es8 _7sp8"><div class="_7esb"><img class="_8zlc _7f2d img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83008415_652417658629610_2770151458065088512_n.svg?_nc_cat=105&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=JL-yrFaGa0MAX_Ix4aj&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=1301b434dd96e2480bc344788a5d6c5b&amp;oe=5FBAFF22" alt="" /></div><div class="_7esd"><img class="_8zlc _7f2d img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83008415_652417658629610_2770151458065088512_n.svg?_nc_cat=105&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=JL-yrFaGa0MAX_Ix4aj&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=1301b434dd96e2480bc344788a5d6c5b&amp;oe=5FBAFF22" alt="" /></div></div></a></div><div class="_7sp9"><a href="https://l.facebook.com/l.php?u=https%3A%2F%2Ftwitter.com%2Ffacebookai&amp;h=AT1lPD9XaEQBGB3T0fxr236jFGfwvcBZtEoB1iQ_5BnRyODQYVXpyEXQW0naIuEmSMf3NAsjOZzY1aYy2Jt1B6k9hZ5pNS0UNznA_ENZgwd-98PwnZ8dEmCp9fpU2UnR46afZ_Y6PPMaayY1V7k4cO1PyWJXPQ" target="_blank" rel="nofollow" data-lynx-mode="hover"><div class="_7es8 _7sp8"><div class="_7esa"><img class="_8zlc _7f2d img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83504457_657983571406144_3931884461741834240_n.svg?_nc_cat=110&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=rax9u_VnV7wAX-XFI3J&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=6592135c1f466f1334009a60e02611f4&amp;oe=5FB95527" alt="" /></div><div class="_7esc"><img class="_8zlc _7f2d img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83504457_657983571406144_3931884461741834240_n.svg?_nc_cat=110&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=rax9u_VnV7wAX-XFI3J&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=6592135c1f466f1334009a60e02611f4&amp;oe=5FB95527" alt="" /></div></div></a></div></div></div></div></div></div></div></div><div class="_7f9-"><div class="_7fa7"><div class="_7fbm" style="" data-ms="&#123;&quot;creative&quot;:&quot;section&quot;,&quot;creative_detail&quot;:&quot;section&quot;,&quot;create_type&quot;:&quot;section&quot;,&quot;create_type_detail&quot;:&quot;section&quot;&#125;"><div class="_FBAIExpandableCategoryFooter__footerContainer"><div><div class="_7fa0"><div class="_7fa1" id="u_0_1y"><p class="_8w6f _8w6h _7fa9">Tools</p><i class="_FBAIExpandableItem__expandIcon img sp_hCaZRHcTMeh sx_cd141a" id="u_0_1z"></i><i class="_FBAIExpandableItem__collapseIcon hidden_elem img sp_hCaZRHcTMeh sx_0c8331" id="u_0_20"></i></div><div class="_7fa2" id="u_0_21"><div class="_7fab"><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="/tools" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Tools</span></a><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="/tools#frameworks-and-tools" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Frameworks &amp; Tools
            </span></a></div></div></div><div class="_7fa0"><div class="_7fa1" id="u_0_22"><p class="_8w6f _8w6h _7fa9">Research</p><i class="_FBAIExpandableItem__expandIcon img sp_hCaZRHcTMeh sx_cd141a" id="u_0_23"></i><i class="_FBAIExpandableItem__collapseIcon hidden_elem img sp_hCaZRHcTMeh sx_0c8331" id="u_0_24"></i></div><div class="_7fa2" id="u_0_25"><div class="_7fab"><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="/research" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Research</span></a><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="/research#research-areas" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Research Areas
            </span></a><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="/research#notable-papers" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Notable Papers
            </span></a><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="/research#recent-publications" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Recent Publications
            </span></a><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="/research#fundamental-and-applied" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Fundamental &amp; Applied
            </span></a><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="/research#recent-projects" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Recent Projects
            </span></a></div></div></div><div class="_7fa0"><div class="_7fa1" id="u_0_26"><p class="_8w6f _8w6h _7fa9">Blog</p><i class="_FBAIExpandableItem__expandIcon img sp_hCaZRHcTMeh sx_cd141a" id="u_0_27"></i><i class="_FBAIExpandableItem__collapseIcon hidden_elem img sp_hCaZRHcTMeh sx_0c8331" id="u_0_28"></i></div><div class="_7fa2" id="u_0_29"><div class="_7fab"><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="/blog" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Blog</span></a><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="/blog" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Read Blog
            </span></a></div></div></div><div class="_7fa0"><div class="_7fa1" id="u_0_2a"><p class="_8w6f _8w6h _7fa9">People</p><i class="_FBAIExpandableItem__expandIcon img sp_hCaZRHcTMeh sx_cd141a" id="u_0_2b"></i><i class="_FBAIExpandableItem__collapseIcon hidden_elem img sp_hCaZRHcTMeh sx_0c8331" id="u_0_2c"></i></div><div class="_7fa2" id="u_0_2d"><div class="_7fab"><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="/results/?page=1&amp;sort_by=random&amp;content_types[0]=person" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">People</span></a><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="/results/?page=1&amp;sort_by=random&amp;content_types[0]=person" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              People Profiles
            </span></a></div></div></div><div class="_7fa0"><div class="_7fa1" id="u_0_2e"><p class="_8w6f _8w6h _7fa9">Join Us</p><i class="_FBAIExpandableItem__expandIcon img sp_hCaZRHcTMeh sx_cd141a" id="u_0_2f"></i><i class="_FBAIExpandableItem__collapseIcon hidden_elem img sp_hCaZRHcTMeh sx_0c8331" id="u_0_2g"></i></div><div class="_7fa2" id="u_0_2h"><div class="_7fab"><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="https://www.facebook.com/careers/jobs?sub_teams[0]=Artificial%20Intelligence" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Join Us</span></a><a class="_8xc5 _8y8i _8x97 _8w61 _7faa" href="https://www.facebook.com/careers/jobs?sub_teams[0]=Artificial%20Intelligence" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">
              Jobs
            </span></a></div></div></div></div></div><div class="_7ota"><div class="_7sp9"><a href="https://www.facebook.com/facebookai" target="_blank"><div class="_7es8 _7sp8"><div class="_7esb"><img class="_8zlc _7f2d img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83008415_652417658629610_2770151458065088512_n.svg?_nc_cat=105&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=JL-yrFaGa0MAX_Ix4aj&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=1301b434dd96e2480bc344788a5d6c5b&amp;oe=5FBAFF22" alt="" /></div><div class="_7esd"><img class="_8zlc _7f2d img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83008415_652417658629610_2770151458065088512_n.svg?_nc_cat=105&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=JL-yrFaGa0MAX_Ix4aj&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=1301b434dd96e2480bc344788a5d6c5b&amp;oe=5FBAFF22" alt="" /></div></div></a></div><div class="_7sp9"><a href="https://l.facebook.com/l.php?u=https%3A%2F%2Ftwitter.com%2Ffacebookai&amp;h=AT3AT8xlg-D1Izip2CzKCLJeQHvyGOYYlFe59kw4hY5_AIGJ5bcupOg84-dfGMdg8pvt76N093bBbBLNaLpAyZcHVHtC8336snHz4WyhcrpWBljuYHe2LI2WsgpB197QX3AB9n34odorCNj1" target="_blank" rel="nofollow" data-lynx-mode="hover"><div class="_7es8 _7sp8"><div class="_7esa"><img class="_8zlc _7f2d img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83504457_657983571406144_3931884461741834240_n.svg?_nc_cat=110&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=rax9u_VnV7wAX-XFI3J&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=6592135c1f466f1334009a60e02611f4&amp;oe=5FB95527" alt="" /></div><div class="_7esc"><img class="_8zlc _7f2d img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83504457_657983571406144_3931884461741834240_n.svg?_nc_cat=110&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=rax9u_VnV7wAX-XFI3J&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=6592135c1f466f1334009a60e02611f4&amp;oe=5FB95527" alt="" /></div></div></a></div></div></div></div></div><div class="_8za3" data-ms="&#123;&quot;creative&quot;:&quot;section&quot;,&quot;creative_detail&quot;:&quot;section&quot;,&quot;create_type&quot;:&quot;section&quot;,&quot;create_type_detail&quot;:&quot;section&quot;&#125;"><div class="_7es3 _8xde"><div class="_7es4"><div class="_7es5"><a class="_8xc5 _8y8i _8x97 _8w61" href="https://www.facebook.com/about/privacy/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Privacy Policy</span></a></div><div class="_7es5"><a class="_8xc5 _8y8i _8x97 _8w61" href="https://www.facebook.com/policies/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Terms</span></a></div><div class="_7es5"><a class="_8xc5 _8y8i _8x97 _8w61" href="https://www.facebook.com/policies/cookies/" data-ms="&#123;&quot;creative&quot;:&quot;link&quot;,&quot;creative_detail&quot;:&quot;link&quot;,&quot;create_type&quot;:&quot;link&quot;,&quot;create_type_detail&quot;:&quot;link&quot;&#125;"><span class="_8x6t _8x94 _8w61 _8w6h">Cookies</span></a></div></div><div class="_8-b_"><div class="_7es6"><p class="_8w6f _8w6h _7fa6"> Facebook © 2020</p></div><div class="_8-c0"><div class="_7sp9"><a href="https://www.facebook.com/facebookai" target="_blank"><div class="_7es8 _7sp8"><div class="_7esb"><img class="_8zlc _7f2d img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83008415_652417658629610_2770151458065088512_n.svg?_nc_cat=105&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=JL-yrFaGa0MAX_Ix4aj&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=1301b434dd96e2480bc344788a5d6c5b&amp;oe=5FBAFF22" alt="" /></div><div class="_7esd"><img class="_8zlc _7f2d img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83008415_652417658629610_2770151458065088512_n.svg?_nc_cat=105&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=JL-yrFaGa0MAX_Ix4aj&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=1301b434dd96e2480bc344788a5d6c5b&amp;oe=5FBAFF22" alt="" /></div></div></a></div><div class="_7sp9"><a href="https://l.facebook.com/l.php?u=https%3A%2F%2Ftwitter.com%2Ffacebookai&amp;h=AT1O67RQWyZJxTVWr6jDzt66Gs6FM7huHokfwy0EK2mggbTT5uGGzxApgECc7ZwwwEojtVjqpFbxvp6g2kg1FavrE5Mthy9AGHs4mXzI3MdK4eBPAw0leCjIHwBHFT33OLCCg0T8pQqaPsPn" target="_blank" rel="nofollow" data-lynx-mode="hover"><div class="_7es8 _7sp8"><div class="_7esa"><img class="_8zlc _7f2d img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83504457_657983571406144_3931884461741834240_n.svg?_nc_cat=110&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=rax9u_VnV7wAX-XFI3J&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=6592135c1f466f1334009a60e02611f4&amp;oe=5FB95527" alt="" /></div><div class="_7esc"><img class="_8zlc _7f2d img" src="https://scontent-iad3-1.xx.fbcdn.net/v/t39.2365-6/83504457_657983571406144_3931884461741834240_n.svg?_nc_cat=110&amp;ccb=2&amp;_nc_sid=ad8a9d&amp;_nc_ohc=rax9u_VnV7wAX-XFI3J&amp;_nc_ht=scontent-iad3-1.xx&amp;oh=6592135c1f466f1334009a60e02611f4&amp;oe=5FB95527" alt="" /></div></div></a></div></div></div></div></div></div><noscript></noscript></div><div id="pagelet_dock" data-referrer="pagelet_dock" data-visualcompletion="ignore"></div></div>
<script>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</script>
<script>requireLazy(["InitialJSLoader"], function(InitialJSLoader) {InitialJSLoader.loadOnDOMContentReady(["LmicE","HVb4M","S2wlN","498nw","N7XTW","HaMqt","VCivs","FCfAi","PNQoF","vXvTg","KurNM","CKkID","U7wow","PCBJ3","XyMd0","\/ipQK","bRvbN","nkD4T","8jSBK"]);});</script>
<script>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</script>
<link rel="preload" href="https://static.xx.fbcdn.net/rsrc.php/v3/yI/l/0,cross/q3mHt82SoA9.css?_nc_x=Ij3Wp8lg5Kz" as="style" />
<link rel="preload" href="https://static.xx.fbcdn.net/rsrc.php/v3/yC/l/0,cross/tlx15XEt5Mh.css?_nc_x=Ij3Wp8lg5Kz" as="style" />
<link rel="preload" href="https://static.xx.fbcdn.net/rsrc.php/v3/yQ/l/0,cross/6ObU0DPn-Ad.css?_nc_x=Ij3Wp8lg5Kz" as="style" />
<link rel="preload" href="https://static.xx.fbcdn.net/rsrc.php/v3/yF/l/0,cross/pWMr2ApQuqh.css?_nc_x=Ij3Wp8lg5Kz" as="style" />
<link rel="preload" href="https://static.xx.fbcdn.net/rsrc.php/v3/yH/l/0,cross/7K1ZHH8VS5b.css?_nc_x=Ij3Wp8lg5Kz" as="style" />
<link rel="preload" href="https://static.xx.fbcdn.net/rsrc.php/v3/yO/l/0,cross/rNPwv-K48lK.css?_nc_x=Ij3Wp8lg5Kz" as="style" />
<link rel="preload" href="https://static.xx.fbcdn.net/rsrc.php/v3/yU/l/0,cross/2iEZgM2HUCy.css?_nc_x=Ij3Wp8lg5Kz" as="style" />
<link rel="preload" href="https://static.xx.fbcdn.net/rsrc.php/v3i7M54/yA/l/en_US/Xo_xUCTI91a.js?_nc_x=Ij3Wp8lg5Kz" as="script" nonce="oPMEiBFx" />
<link rel="preload" href="https://static.xx.fbcdn.net/rsrc.php/v3iBFM4/yL/l/en_US/hG26mHgLHdF.js?_nc_x=Ij3Wp8lg5Kz" as="script" nonce="oPMEiBFx" />
<link rel="preload" href="https://static.xx.fbcdn.net/rsrc.php/v3ifXM4/yc/l/en_US/2dashs9Ye4v.js?_nc_x=Ij3Wp8lg5Kz" as="script" nonce="oPMEiBFx" />
<link rel="preload" href="https://static.xx.fbcdn.net/rsrc.php/v3/yy/l/0,cross/g1H2niWdvH7.css?_nc_x=Ij3Wp8lg5Kz" as="style" />
<link rel="preload" href="https://static.xx.fbcdn.net/rsrc.php/v3/yO/l/0,cross/pZqFVKEF2tq.css?_nc_x=Ij3Wp8lg5Kz" as="style" />
<script>now_inl=(function(){var p=window.performance;return p&&p.now&&p.timing&&p.timing.navigationStart?function(){return p.now()+p.timing.navigationStart}:function(){return new Date().getTime()};})();requireLazy(["BigPipe"],function(BigPipe){define("__bigPipe",[],window.bigPipe=new BigPipe({"forceFinish":true,"config":null}));});</script>
<script nonce="oPMEiBFx">(function(){var n=now_inl();requireLazy(["__bigPipe"],function(bigPipe){bigPipe.beforePageletArrive("first_response",n);})})();</script>
<script nonce="oPMEiBFx">requireLazy(["__bigPipe"],(function(bigPipe){bigPipe.onPageletArrive({displayResources:["q0yL9","j1sKK","dow/I","/01Fl","+2o4K","IyDqr","1mO9I","498nw","HaMqt","PCBJ3","EZUnI","C42Om"],id:"first_response",phase:0,last_in_phase:true,tti_phase:0,all_phases:[63,62],hsrp:{hblp:{sr_revision:1002879894,consistency:{rev:1002879894}}},allResources:["LmicE","HVb4M","S2wlN","498nw","N7XTW","HaMqt","q0yL9","VCivs","FCfAi","PNQoF","vXvTg","j1sKK","dow/I","/01Fl","+2o4K","KurNM","CKkID","IyDqr","1mO9I","U7wow","PCBJ3","XyMd0","/ipQK","EZUnI","C42Om","bRvbN","nkD4T","8jSBK"]});}));</script>
<script>requireLazy(["__bigPipe"],function(bigPipe){bigPipe.setPageID("6887286870294925013-0")});CavalryLogger.setPageID("6887286870294925013-0");</script>

<script nonce="oPMEiBFx">(function(){var n=now_inl();requireLazy(["__bigPipe"],function(bigPipe){bigPipe.beforePageletArrive("pagelet_dock",n);})})();</script>
<script nonce="oPMEiBFx">requireLazy(["__bigPipe"],(function(bigPipe){bigPipe.onPageletArrive({displayResources:["/01Fl"],id:"pagelet_dock",phase:1,last_in_phase:true,last_pagelet:true,tti_phase:1,jsmods:{require:[["AsyncRequestNectarLogging"],["Bootloader","markComponentsAsImmediate",[],[["BanzaiODS","FbtLogging","BanzaiScuba"]]]]},hsrp:{hblp:{sr_revision:1002879894,consistency:{rev:1002879894}}},allResources:["KurNM","498nw","HaMqt","/01Fl","U7wow"]});}));</script>                                                                                                                                                                                                                                                                                                                                                                                                       <script nonce="oPMEiBFx">(function(){var n=now_inl();requireLazy(["__bigPipe"],function(bigPipe){bigPipe.beforePageletArrive("last_response",n);})})();</script>
<script nonce="oPMEiBFx">requireLazy(["__bigPipe"],(function(bigPipe){bigPipe.onPageletArrive({displayResources:["498nw"],id:"last_response",phase:2,last_in_phase:true,the_end:true,jsmods:{define:[["TimeSliceInteractionSV",[],{on_demand_reference_counting:true,on_demand_profiling_counters:true,default_rate:1000,lite_default_rate:100,interaction_to_lite_coinflip:{ADS_INTERFACES_INTERACTION:0,ads_perf_scenario:0,ads_wait_time:0,Event:1},interaction_to_coinflip:{ADS_INTERFACES_INTERACTION:1,ads_perf_scenario:1,ads_wait_time:1,Event:100},enable_heartbeat:true,maxBlockMergeDuration:0,maxBlockMergeDistance:0,enable_banzai_stream:true,user_timing_coinflip:50,banzai_stream_coinflip:1,compression_enabled:true,ref_counting_fix:false,ref_counting_cont_fix:false,also_record_new_timeslice_format:false,force_async_request_tracing_on:false},2609],["cr:1069930",[],{__rc:[null,"Aa3ArY1-mBTPvot_L6Tllm46NrlNA1IF0ugNOKOvI8i1O_4mx_6jEtLc1M4t8P1Q0xLCWPpi_Jv0pDgXjbu1NRc"]},-1],["cr:1083116",["XAsyncRequest"],{__rc:["XAsyncRequest","Aa3ArY1-mBTPvot_L6Tllm46NrlNA1IF0ugNOKOvI8i1O_4mx_6jEtLc1M4t8P1Q0xLCWPpi_Jv0pDgXjbu1NRc"]},-1],["cr:1083117",[],{__rc:[null,"Aa3ArY1-mBTPvot_L6Tllm46NrlNA1IF0ugNOKOvI8i1O_4mx_6jEtLc1M4t8P1Q0xLCWPpi_Jv0pDgXjbu1NRc"]},-1],["cr:1697455",["CookieConsentActionHandler"],{__rc:["CookieConsentActionHandler","Aa3ArY1-mBTPvot_L6Tllm46NrlNA1IF0ugNOKOvI8i1O_4mx_6jEtLc1M4t8P1Q0xLCWPpi_Jv0pDgXjbu1NRc"]},-1],["KillabyteProfilerConfig",[],{htmlProfilerModule:null,profilerModule:null,depTypes:{BL:"bl",NON_BL:"non-bl"}},1145],["QuicklingConfig",[],{version:"1002879894;0;",sessionLength:10,inactivePageRegex:"^/(fr/u\\.php|ads/|advertising|ac\\.php|ae\\.php|a\\.php|ajax/emu/(end|f|h)\\.php|badges/|comments\\.php|connect/uiserver\\.php|editalbum\\.php.+add=1|ext/|feeds/|help([/?]|$)|identity_switch\\.php|isconnectivityahumanright/|intern/|login\\.php|logout\\.php|sitetour/homepage_tour\\.php|sorry\\.php|syndication\\.php|webmessenger|/plugins/subscribe|lookback|brandpermissions|gameday|pxlcld|comet|worldcup/map|livemap|work/reseller|([^/]+/)?dialog|legal|.+\\.pdf$|.+/settings/)",badRequestKeys:["nonce","access_token","oauth_token","xs","checkpoint_data","code"],logRefreshOverhead:false},60],["TrackingConfig",[],{domain:"https://pixel.facebook.com"},325],["BrowserPaymentHandlerConfig",[],{enabled:false},3904],["TimeSpentConfig",[],{"0_delay":0,"0_timeout":8,delay:1000,timeout:64},142],["cr:844180",["TimeSpentImmediateActiveSecondsLoggerBlue"],{__rc:["TimeSpentImmediateActiveSecondsLoggerBlue","Aa3ArY1-mBTPvot_L6Tllm46NrlNA1IF0ugNOKOvI8i1O_4mx_6jEtLc1M4t8P1Q0xLCWPpi_Jv0pDgXjbu1NRc"]},-1],["cr:1187159",["BlueCompatBroker"],{__rc:["BlueCompatBroker","Aa3ArY1-mBTPvot_L6Tllm46NrlNA1IF0ugNOKOvI8i1O_4mx_6jEtLc1M4t8P1Q0xLCWPpi_Jv0pDgXjbu1NRc"]},-1],["cr:1634616",["UserActivityBlue"],{__rc:["UserActivityBlue","Aa3ArY1-mBTPvot_L6Tllm46NrlNA1IF0ugNOKOvI8i1O_4mx_6jEtLc1M4t8P1Q0xLCWPpi_Jv0pDgXjbu1NRc"]},-1],["ImmediateActiveSecondsConfig",[],{sampling_rate:0},423]],require:[["TrackingPixel","loadWithNoReferrer",[],["https://cx.atdmt.com/?f=AYy51zVOawPbdgqNyF72mairQ3aKg36LjHFQV2Csy_JNrasYysQXO_gIm0KJSPginnoZBpZfqrc5YaFfdNwKviXo&c=1349625931&v=1&l=2"]],["CavalryLoggerImpl","startInstrumentation",[],[]],["NavigationMetrics","setPage",[],[{page:"XFBAIBlogChildController",page_type:"normal",page_uri:"https://ai.facebook.com/blog/ppl-bench-creating-a-standard-for-benchmarking-probabilistic-programming-languages/",serverLID:"6887286870294925013-0"}]],["DimensionTracking"],["HighContrastMode","init",[],[{isHCM:false,spacerImage:"https://static.xx.fbcdn.net/rsrc.php/v3/y4/r/-PAXP-deijE.gif"}]],["ClickRefLogger"],["DetectBrokenProxyCache","run",[],[0,"c_user"]],["NavigationClickPointHandler"],["Artillery","disable",[],[]],["ScriptPathLogger","startLogging",[],[]],["TimeSpentBitArrayLogger","init",[],[]],["CookieCore","setWithoutChecksIfFirstPartyContext",[],["_js_datr","646UXxzzc8D-gNmPzvPla9oE",63072000000,"/",true]],["Bootloader","markComponentsAsImmediate",[],[["VisualCompletionGating"]]]]},hsrp:{hsdp:{clpData:{"1743690":{r:1}},gkxData:{"1427308":{result:false,hash:"AT4MsUJXwuSiYJppvSE"}}},hblp:{sr_revision:1002879894,consistency:{rev:1002879894},rsrcMap:{fQxVP:{type:"js",src:"https://static.xx.fbcdn.net/rsrc.php/v3iqES4/yC/l/en_US/9uUhEN-sUI-.js?_nc_x=Ij3Wp8lg5Kz",nc:1},FEt5G:{type:"js",src:"https://static.xx.fbcdn.net/rsrc.php/v3/yH/r/7oVtGLsr9D2.js?_nc_x=Ij3Wp8lg5Kz",nc:1},"ujL8/":{type:"js",src:"https://static.xx.fbcdn.net/rsrc.php/v3/yu/r/jnuFTNJnMhL.js?_nc_x=Ij3Wp8lg5Kz",nc:1}}}},allResources:["LmicE","fQxVP","FEt5G","498nw","ujL8/","HaMqt","yNdQV","/Wisi","U7wow","KurNM"],onload:["CavalryLogger.getInstance(\"6887286870294925013-0\").setTTIEvent(\"t_domcontent\");"],onafterload:["CavalryLogger.getInstance(\"6887286870294925013-0\").collectBrowserTiming(window)","window.CavalryLogger&&CavalryLogger.getInstance().setTimeStamp(\"t_paint\");","if (window.ExitTime){CavalryLogger.getInstance(\"6887286870294925013-0\").setValue(\"t_exit\", window.ExitTime);};"]});}));</script></body></html>